PHP is one of the most widely used open-source server-side programming languages. It is extremely popular because it’s free software, which you can use to build interactive websites such as community websites, shopping portals or e-teaching websites as opposed to static HTML websites. A PHP module must be available on the server where a PHP site is hosted so that its source code can be ‘translated’. As there aren’t any license charges for such a module and the language itself provides innumerable possibilities for the Internet applications that you build, there are 100s of millions of PHP-powered websites. What’s more, there’re a large number of PHP scripts, which you can use for your websites without needing to possess any coding skills. Considering the fact that there’re different PHP versions, you should confirm whether the same version that you used whilst building your website is available on the web server as well.

PHP 4, PHP 5 and PHP 7 Support in Hosting

Our hosting servers support several PHP versions, which implies that your websites will run without any problem no matter if your scripts are out of date. We realize that an old website does not automatically equal a vulnerable one as you may have performed a lot of mods to its source code. That is the reason why we support PHP 4, PHP 5 and PHP 7 and you can select which one will be enabled for your shared web hosting account. You can change the version with one mouse click from your Hepsia Control Panel and the new settings will be applied momentarily. In case you’d like to run both older and newer scripts, there’s even an option to use a different PHP version for each domain of yours simultaneously.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting

In case you have a website built using an earlier version of PHP and you have devoted time and energy towards setting it up, fixing security loopholes and embedding web page content, you will need a web hosting service that can support it, since the vast majority of web hosting providers today offer support only for the most recently unveiled PHP version and give up the earlier versions. We, however, have decided to permit you to select the version that your own websites need. Our semi-dedicated hosting support PHP 4, PHP 5 and PHP 7, so you’ll be able to use both older and newer scripts without forfeiting any custom settings or frittering away time and efforts striving to make your sites compatible with the web hosting environment. The current version can be changed via the Hepsia hosting Control Panel and such a change will apply to the entire account, but you’ll also have the ability to choose a different version for each individual site hosted in your account by using an .htaccess file.